Modern Events Calendar <= 7.11.0 - Authenticated (Subscriber+) Arbitrary File Upload

8.8
Unrestricted Upload of File with Dangerous Type
CVE CVE-2024-5441
CVSS 8.8 (High)
Publicly Published July 8, 2024
Last Updated July 9, 2024
Researcher Foxyyy

Description

The Modern Events Calendar plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the set_featured_image function in all versions up to, and including, 7.11.0. This makes it possible for authenticated attackers, with subscriber access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. The plugin allows administrators (via its settings) to extend the ability to submit events to unauthenticated users, which would allow unauthenticated attackers to exploit this vulnerability.

Wordfence blocked 38 attacks targeting this vulnerability in the past 24 hours.

References

Share

2 affected software packages

Software Type Plugin
Software Slug modern-events-calendar
Patched? Yes
Remediation Update to version 7.12.0, or a newer patched version
Affected Version
  • <= 7.11.0
Patched Version
  • 7.12.0
Software Type Plugin
Software Slug modern-events-calendar-lite (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.12.0, or a newer patched version
Affected Version
  • <= 7.11.0
Patched Version
  • 7.12.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation