WordPress Core < 5.9.2 & Gutenberg < 12.7.2 - Prototype Pollution via Block Editor

5.4
Improperly Controlled Modification of Dynamically-Determined Object Attributes
CVSS 5.4 (Medium)
Publicly Published March 11, 2022
Last Updated January 22, 2024
Researcher Researchers from Johns Hopkins University

Description

WordPress Core in various versions < 5.9.2 and Gutenberg versions less than 12.7.2 are vulnerable to prototype pollution via the block editor which could make injecting malicious web scripts possible in some cases.

Wordfence blocked 11,200 attacks targeting this vulnerability in the past 24 hours.

References

Share

2 affected software packages

Software Type Plugin
Software Slug gutenberg (view on wordpress.org)
Patched? Yes
Remediation Update to version 12.7.2, or a newer patched version
Affected Version
  • < 12.7.2
Patched Version
  • 12.7.2
Software Type Core
Patched? Yes
Remediation Update to one of the following versions, or a newer patched version: 3.7.38, 3.8.38, 3.9.36, 4.0.35, 4.1.35, 4.2.32, 4.3.28, 4.4.27, 4.5.26, 4.6.23, 4.7.23, 4.8.19, 4.9.20, 5.0.16, 5.1.13, 5.2.15, 5.3.12, 5.4.10, 5.5.9, 5.6.8, 5.7.6, 5.8.4, 5.9.2
Affected Versions
  • < 3.7
  • 5.4 - 5.4.9
  • 5.5 - 5.5.8
  • 5.6 - 5.6.7
Expand to see 20 more affected version ranges.
  • 5.7 - 5.7.5
  • 5.8 - 5.8.3
  • 5.9 - 5.9.1
  • 3.7 - 3.7.37
  • 3.8 - 3.8.37
  • 3.9 - 3.9.35
  • 4.0 - 4.0.34
  • 4.1 - 4.1.34
  • 4.2 - 4.2.31
  • 4.3 - 4.3.27
  • 4.4 - 4.4.26
  • 4.5 - 4.5.25
  • 4.6 - 4.6.22
  • 4.7 - 4.7.22
  • 4.8 - 4.8.18
  • 4.9 - 4.9.19
  • 5.0 - 5.0.15
  • 5.1 - 5.1.12
  • 5.2 - 5.2.14
  • 5.3 - 5.3.11
Patched Versions
  • 3.7.38
  • 3.8.38
  • 3.9.36
  • 4.0.35
Expand to see 19 more patched versions.
  • 4.1.35
  • 4.2.32
  • 4.3.28
  • 4.4.27
  • 4.5.26
  • 4.6.23
  • 4.7.23
  • 4.8.19
  • 4.9.20
  • 5.0.16
  • 5.1.13
  • 5.2.15
  • 5.3.12
  • 5.4.10
  • 5.5.9
  • 5.6.8
  • 5.7.6
  • 5.8.4
  • 5.9.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation