Advanced Custom Fields <= 5.12.2 - File Upload

4.3
Missing Authorization
CVE CVE-2022-2594
CVSS 4.3 (Medium)
Publicly Published July 14, 2022
Last Updated January 18, 2023
Researcher James Golovich

Description

The Advanced Custom Fields plugin for WordPress has a file upload vulnerability in versions up to, and including, 5.12.2. This allows users without the upload_files capability, such as contributors, or unauthenticated users in cases where a frontend form is added to the site, to upload allowed file types. The upload is handled by WordPress so file type and extension checks still occur, though this could potentially be used by high-privileged users in certain locked-down configurations to bypass other security mechanisms and upload dangerous file types.

References

Share

1 affected software package

Software Type Plugin
Software Slug advanced-custom-fields (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.12.3, or a newer patched version
Affected Version
  • <= 5.12.2
Patched Version
  • 5.12.3

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation