Complianz <= 6.4.5 (Premium <= 6.4.7) - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-34030
CVSS 4.3 (Medium)
Publicly Published June 20, 2023
Last Updated January 22, 2024
Researcher Rafie Muhammad - Patchstack


The Complianz plugin for WordPress is vulnerable to Cross-Site Request Forgery to Stored Cross-Site Scripting in versions up to, and including, 6.4.5 (Free) and 6.4.7 (Premium). This is due to missing nonce validation on several functions called via AJAX actions such as cmplz_delete_cookiebanner(), cmplz_duplicate_cookiebanner(), maybe_install_suggested_plugins (), and ajax_create_pages() to list a few. This makes it possible for unauthenticated attackers to invoke these functions and perform multiple actions like deleting/duplicating cookie banners installing suggested plugins, creating pages, and more via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Complianz – GDPR/CCPA Cookie Consent

Software Type Plugin
Software Slug complianz-gdpr (view on
Patched? Yes
Remediation Update to version 6.4.6, or a newer patched version
Affected Version
  • <= 6.4.5
Patched Version
  • 6.4.6

1 other affected software package

Software Type Plugin
Software Slug complianz-gdpr-premium (view on
Patched? Yes
Remediation Update to version 6.4.8, or a newer patched version
Affected Version
  • <= 6.4.7
Patched Version
  • 6.4.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.