Complianz Free <= 6.3.3 & Premium <= 6.3.5 - SQL Injection via Translations

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2022-3494
CVSS 8.8 (High)
Publicly Published October 17, 2022
Last Updated January 18, 2023
Researcher Sakri Rafael Koskimies


The Complianz plugin for WordPress is vulnerable to SQL Injection via unescaped translations in versions up to, and including, 6.3.3 (Free) and 6.3.5 (Premium) due to insufficient escaping on the user supplied translation (either from a translation file or a user with translator role through a translation plugin) and lack of sufficient preparation on the existing SQL query. This makes it possible for attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.



2 affected software packages

Software Type Plugin
Software Slug complianz-gdpr (view on
Patched? Yes
Remediation Update to version 6.3.4, or a newer patched version
Affected Version
  • <= 6.3.3
Patched Version
  • 6.3.4
Software Type Plugin
Software Slug complianz-gdpr-premium (view on
Patched? Yes
Remediation Update to version 6.3.6, or a newer patched version
Affected Version
  • <= 6.3.5
Patched Version
  • 6.3.6

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.