Complianz | GDPR/CCPA Cookie Consent <= 6.4.5 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-34030
CVSS 4.3 (Medium)
Publicly Published May 30, 2023
Last Updated June 22, 2023
Researcher Rafie Muhammad - Patchstack


The Complianz | GDPR/CCPA Cookie Consent plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 6.4.5. This is due to missing nonce validation on the process_ajax_destination_clear, dismiss_review_notice_callback, and dismiss_warning functions. This makes it possible for unauthenticated attackers to dismiss review notices, disabled the plugin, and dismiss warnings via forged requests granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Complianz – GDPR/CCPA Cookie Consent

Software Type Plugin
Software Slug complianz-gdpr (view on
Patched? Yes
Remediation Update to version 6.4.6, or a newer patched version
Affected Version
  • < 6.4.6
Patched Version
  • 6.4.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.