Delete Duplicate Posts <= 4.8.9 - Missing Authorization via AJAX Actions

Missing Authorization
CVE CVE-2023-47754
CVSS 5.4 (Medium)
Publicly Published November 13, 2023
Last Updated January 22, 2024
Researcher Huynh Tien Si


The Delete Duplicate Posts plugin for WordPress is vulnerable to unauthorized deletion of data due to a missing capability check on some of its AJAX actions in all versions up to 4.9 (exclusive). This makes it possible for authenticated attackers, with subscriber access or higher, to delete duplicate posts, access plugin logs, and opt in to Freemius data gathering.



Vulnerability Details for Delete Duplicate Posts

Software Type Plugin
Software Slug delete-duplicate-posts (view on
Patched? Yes
Remediation Update to version 4.9, or a newer patched version
Affected Version
  • < 4.9
Patched Version
  • 4.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.