WordPress Gallery Plugin – NextGEN Gallery <= 3.38 - Authenticated (Admin+) Local File Inclusion

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-3279
CVSS 4.9 (Medium)
Publicly Published September 25, 2023
Last Updated October 19, 2023
Researcher Alex Sanford


The WordPress Gallery Plugin – NextGEN Gallery plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 3.38 via the 'Select View' field in the plugin's developer tools. This makes it possible for authenticated attackers, with administrator-level access and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.



Vulnerability Details for Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery

Software Type Plugin
Software Slug nextgen-gallery (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.39, or a newer patched version
Affected Version
  • <= 3.38
Patched Version
  • 3.39

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.