Welcart e-Commerce <= 2.9.14 - Missing Authorization

Missing Authorization
CVE CVE-2024-32144
CVSS 5.4 (Medium)
Publicly Published April 12, 2024
Last Updated April 17, 2024
Researcher emad


The Welcart e-Commerce plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the usces_item_duplicate() function in versions up to, and including, 2.9.14. This makes it possible for authenticated attackers, with author-level access and above, to duplicate other authors posts.



Vulnerability Details for Welcart e-Commerce

Software Type Plugin
Software Slug usc-e-shop (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.10.0, or a newer patched version
Affected Version
  • <= 2.9.14
Patched Version
  • 2.10.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.