WooCommerce < 5.5 - Authenticated Blind SQL Injection

8.8
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2021-32790
CVSS 8.8 (High)
Publicly Published July 13, 2021
Last Updated January 22, 2024
Researcher Josh (jl-dos)

Description

Woocommerce is an open source eCommerce plugin for WordPress. An SQL injection vulnerability impacts all WooCommerce sites running the WooCommerce plugin between version 3.3.0 and 5.5. Malicious actors (already) having admin access, or API keys to the WooCommerce site can exploit vulnerable endpoints of `/wp-json/wc/v3/webhooks`, `/wp-json/wc/v2/webhooks` and other webhook listing API. Read-only SQL queries can be executed using this exploit, while data will not be returned, by carefully crafting `search` parameter information can be disclosed using timing and related attacks. Version 3.3.6 is the earliest version of Woocommerce with a patch for this vulnerability. There are no known workarounds other than upgrading.

Wordfence blocked 2,673 attacks targeting this vulnerability in the past 24 hours.

References

Share

1 affected software package

Software Type Plugin
Software Slug woocommerce (view on wordpress.org)
Patched? Yes
Remediation Update to one of the following versions, or a newer patched version: 3.3.6, 3.4.8, 3.5.9, 3.6.6, 3.7.2, 3.8.2, 3.9.4, 4.0.2, 4.1.2, 4.2.3, 4.3.4, 4.4.2, 4.5.3, 4.6.3, 4.7.2, 4.8.1, 4.9.3, 5.0.1, 5.1.1, 5.2.3, 5.3.1, 5.4.2, 5.5.1, 5.5.2
Affected Versions
  • 4.8 - 4.8
  • 5.0 - 5.0
  • 5.1 - 5.1
  • 5.3 - 5.3
Expand to see 20 more affected version ranges.
  • 5.5 - 5.5
  • < 3.3
  • 3.3 - 3.3.5
  • 3.4 - 3.4.7
  • 3.5 - 3.5.8
  • 3.6 - 3.6.5
  • 3.7 - 3.7.1
  • 3.8 - 3.8.1
  • 3.9 - 3.9.3
  • 4.0 - 4.0.1
  • 4.1 - 4.1.1
  • 4.2 - 4.2.2
  • 4.3 - 4.3.3
  • 4.4 - 4.4.1
  • 4.5 - 4.5.2
  • 4.6 - 4.6.2
  • 4.7 - 4.7.1
  • 4.9 - 4.9.2
  • 5.2 - 5.2.2
  • 5.4 - 5.4.1
Patched Versions
  • 3.3.6
  • 3.4.8
  • 3.5.9
  • 3.6.6
Expand to see 20 more patched versions.
  • 3.7.2
  • 3.8.2
  • 3.9.4
  • 4.0.2
  • 4.1.2
  • 4.2.3
  • 4.3.4
  • 4.4.2
  • 4.5.3
  • 4.6.3
  • 4.7.2
  • 4.8.1
  • 4.9.3
  • 5.0.1
  • 5.1.1
  • 5.2.3
  • 5.3.1
  • 5.4.2
  • 5.5.1
  • 5.5.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation