WP Directory Kit

Information

Software Type Plugin
Software Slug wpdirectorykit (view on wordpress.org)
Software Status Active
Software Author listingthemes
Software Website wpdirectorykit.com
Software Downloads 50,239
Software Active Installs 3,000
Software Record Last Updated June 25, 2024

10 Vulnerabilities

Title Status CVE ID CVSS Researchers Date
WP Directory Kit <= 1.3.0 - Authenticated (Subscriber+) SQL Injection Patched CVE-2024-3217 8.8 Lucio Sá April 4, 2024
WP Directory Kit <= 1.2.9 - Reflected Cross-Site Scripting Patched CVE-2024-29774 6.1 Dimas Maulana March 25, 2024
WP Directory Kit <= 1.2.6 - Missing Authorization Patched CVE-2023-41875 5.3 Debangshu Kundu, Arpeet Rathi September 5, 2023
WP Directory Kit <= 1.2.3 - Missing Authorization to Plugin Settings Change/Delete, Demo Import, Directory Kit Deletion via wdk_admin_action Patched CVE-2023-2351 6.5 István Márton June 12, 2023
WP Directory Kit <= 1.2.3 - Reflected Cross-Site Scripting via 'search' Patched CVE-2023-2835 6.1 Dongzhu Li June 1, 2023
WP Directory Kit <= 1.1.9 - Unauthenticated Local File Inclusion via wdk_public_action Patched CVE-2023-2278 9.8 István Márton May 26, 2023
WP Directory Kit <= 1.2.2 - Missing Authorization to Plugin Installation, Settings Change/Delete, Demo Import, Directory Kit Deletion via wdk_public_action Patched CVE-2023-2280 6.5 István Márton, Ram May 2, 2023
WP Directory Kit <= 1.2.1 - Cross-Site Request Forgery to Plugin Settings Change/Delete, Demo Import, Directory Kit Modification/Deletion via admin_page_display Patched CVE-2023-2279 5.4 István Márton April 28, 2023
WP Directory Kit <= 1.1.9 - Cross-Site Request Forgery to Stored Cross-Site Scripting via wdk_resultitem Patched CVE-2023-2277 6.1 István Márton April 28, 2023
WP Directory Kit <= 1.1.9 - Open Redirect Patched CVE-2023-31229 5.4 Nguyen Xuan Chien April 27, 2023

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation