Alex Thomas

Organization: Wordfence

46
All Time Ranking
68
All Time Discoveries

About

Senior Vulnerability Researcher @Wordfence, OSCP & GPEN

Wordfence Vulnerability Researcher
Wordfence Vulnerability Researcher
November 8, 2023

Showing 1-20 of 68 Vulnerabilities

Title CVE ID CVSS Vector Date
Under Construction <= 3.96 - Cross-Site Request Forgery via admin_action_ucp_dismiss_notice CVE-2023-0831 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N February 10, 2023
Under Construction <= 3.96 - Cross-Site Request Forgery via admin_action_install_weglot CVE-2023-0832 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N February 10, 2023
Weaver Show Posts <= 1.6 - Authenticated(Contributor+) Stored Cross-Site Scripting via Display Name CVE-2023-1404 6.4 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N April 1, 2023
PowerPress <= 10.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVE-2023-1917 5.4 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N April 11, 2023
ShiftController Employee Shift Scheduling <= 4.9.25 - Reflected Cross-Site Scripting via Query String CVE-2023-1978 6.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N April 13, 2023
Locatoraid Store Locator <= 3.9.14 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVE-2023-2031 5.4 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N April 17, 2023
WPCS – WordPress Currency Switcher Professional <= 1.1.9 - Missing Authorization to Arbitrary Custom Drop-Down Currency Switcher Deletion CVE-2023-2556 4.3 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N May 12, 2023
WPCS – WordPress Currency Switcher Professional <= 1.1.9 - Missing Authorization to Arbitrary Custom Drop-Down Currency Switcher Editing CVE-2023-2557 4.3 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N May 12, 2023
WPCS – WordPress Currency Switcher Professional <= 1.1.9 - Missing Authorization to Custom Drop-Down Currency Switcher Creation CVE-2023-2555 4.3 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N May 12, 2023
WPCS – WordPress Currency Switcher Professional <= 1.1.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVE-2023-2558 6.4 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N May 12, 2023
WP EasyCart <= 5.4.8 - Cross-Site Request Forgery via process_bulk_activate_product CVE-2023-2895 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N May 27, 2023
WP EasyCart <= 5.4.8 - Cross-Site Request Forgery via process_delete_product CVE-2023-2891 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N May 27, 2023
WP EasyCart <= 5.4.8 - Cross-Site Request Forgery via process_bulk_delete_product CVE-2023-2892 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N May 27, 2023
WP EasyCart <= 5.4.8 - Cross-Site Request Forgery via process_bulk_deactivate_product CVE-2023-2894 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N May 27, 2023
WP EasyCart <= 5.4.8 - Cross-Site Request Forgery via process_deactivate_product CVE-2023-2893 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N May 27, 2023
WP EasyCart <= 5.4.8 - Cross-Site Request Forgery via process_duplicate_product CVE-2023-2896 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N May 27, 2023
Draw Attention <= 2.0.11 - Missing Authorization to Arbitrary Post Featured Image Modification CVE-2023-2764 4.3 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N May 30, 2023
Brizy Page Builder <= 2.4.18 - IP Address Spoofing to Protection Mechanism Bypass CVE-2023-2897 3.7 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N May 31, 2023
Directorist <= 7.5.4 - Authenticated (Subscriber+) Arbitrary User Password Reset to Privilege Escalation CVE-2023-1888 8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H June 1, 2023
Directorist <= 7.5.4 - Authenticated (Subscriber+) Insecure Direct Object Reference to Arbitrary Post Deletion in listing_task CVE-2023-1889 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N June 1, 2023

Share this researcher's vulnerability discoveries

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation