Directorist <= 7.5.4 - Authenticated (Subscriber+) Insecure Direct Object Reference to Arbitrary Post Deletion in listing_task

Authorization Bypass Through User-Controlled Key
CVE CVE-2023-1889
CVSS 6.5 (Medium)
Publicly Published June 1, 2023
Last Updated June 22, 2023
Researcher Alex Thomas - Wordfence


The Directorist plugin for WordPress is vulnerable to an Insecure Direct Object Reference in versions up to, and including, 7.5.4. This is due to improper validation and authorization checks within the listing_task function. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to delete arbitrary posts. Please note CVE-2023-35052 appears to be a duplicate of this issue.



Vulnerability Details for Directorist – WordPress Business Directory Plugin with Classified Ads Listings

Software Type Plugin
Software Slug directorist (view on
Patched? Yes
Remediation Update to version 7.5.5, or a newer patched version
Affected Version
  • <= 7.5.4
Patched Version
  • 7.5.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.