Welcart e-Commerce

Information

Software Type Plugin
Software Slug usc-e-shop (view on wordpress.org)
Software Status Active
Software Author uscnanbu
Software Website www.welcart.com
Software Downloads 1,044,148
Software Active Installs 20,000
Software Record Last Updated June 18, 2024

Showing 1-20 of 36 Vulnerabilities

8.8
CVE ID Unknown
Nov 14, 2023
Researchers:
8.8
CVE ID Unknown
Nov 28, 2022
Researchers:
8.8
CVE ID Unknown
Nov 16, 2022
Researchers:
8.8
CVE ID Unknown
Feb 8, 2021
Researcher: Erik David Martin
Title Status CVE ID CVSS Researchers Date
Welcart e-Commerce <= 2.9.4 - Unauthenticated PHP Object Injection Patched CVE-2023-5952 9.8 Krzysztof Zając November 10, 2023
Welcart e-Commerce <= 1.8.2 - Authentication Bypass Patched CVE-2016-4828 9.8 Gen Sato June 24, 2016
Welcart e-Commerce <= 2.9.1 - SQL Injection Patched CVE-2014-10017 9.8 HauntIT March 4, 2014
Welcart e-Commerce <= 2.9.4 - Authenticated (Subscriber+) Arbitrary File Upload Patched CVE-2023-5953 8.8 Benachi November 14, 2023
Welcart e-Commerce <= 2.9.4 - Cross-Site Request Forgery Patched 8.8 November 14, 2023
Welcart e-Commerce <= 2.8.21 - Authenticated(Editor+) Arbitrary File Upload Patched CVE-2023-40219 8.8 Akihiro Hashimoto September 26, 2023
Welcart e-Commerce <= 2.8.21 - Authenticated(Editor+) SQL Injection Patched CVE-2023-43610 8.8 Shogo Kumamaru September 14, 2023
Welcart e-Commerce <= 2.8.21 - Authenticated(level_5+) SQL Injection via get_logs Patched CVE-2023-43493 8.8 Shogo Kumamaru September 14, 2023
Welcart e-Commerce <= 2.8.3 - Cross-Site Request Forgery Patched 8.8 November 28, 2022
Welcart e-Commerce <= 2.8.3 - Cross-Site Request Forgery Patched 8.8 November 16, 2022
Welcart e-Commerce <= 2.1.0 - SQL Injection Patched 8.8 Erik David Martin February 8, 2021
Welcart e-Commerce < 1.5.3 - SQL Injection Patched CVE-2015-7791 8.8 Shoji Baba December 17, 2015
Welcart e-Commerce < 1.2.2 - Cross-Site Request Forgery Patched CVE-2012-5178 8.8 Yoshinori Matsumoto December 14, 2012
Welcart e-Commerce < 1.8.3 - Object Injection Patched CVE-2016-4825 8.1 Gen Sato June 24, 2016
Welcart e-Commerce 2.6.10-2.8.4 - Information Disclosure via Arbitrary File Read Patched CVE-2022-4140 7.5 Takeshi Suzuki November 30, 2022
Welcart e-Commerce 2.6.0-2.7.7 - Information Disclosure via Arbitrary File Read Patched CVE-2022-41840 7.5 September 2, 2022
Welcart e-Commerce < 2.2.8 - Missing Capabilities Check to Information Disclosure Patched CVE-2021-4355 7.5 Jerome Bruandet August 6, 2021
Welcart e-Commerce <= 1.9.35 - PHP Object Injection Patched CVE-2020-28339 7.5 Ram November 5, 2020
Welcart e-Commerce <= 2.9.3 - Authenticated(Editor+) SQL Injection Patched CVE-2023-50847 7.2 Muhammad Daffa December 21, 2023
Welcart e-Commerce <= 2.9.5 - Authenticated (Administrator+) PHP Object Injection Patched 7.2 November 15, 2023

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation