Spam protection, Anti-Spam, FireWall by CleanTalk

Information

Software Type Plugin
Software Slug cleantalk-spam-protect (view on wordpress.org)
Software Status Active
Software Author cleantalk
Software Website cleantalk.org
Software Downloads 15,262,191
Software Active Installs 200,000
Software Record Last Updated April 12, 2024

10 Vulnerabilities

Title CVE ID CVSS Researchers Date
Spam protection, AntiSpam, FireWall by CleanTalk <= 6.20 - Cross-Site Request Forgery CVE-2023-51535 4.3 Brandon James Roldan (tomorrowisnew) December 27, 2023
Spam protection, AntiSpam, FireWall by CleanTalk <= 6.20 - Cross-Site Request Forgery via apbct_settings__update_account_email CVE-2023-51696 4.3 Elliot December 27, 2023
Spam protection, AntiSpam, FireWall by CleanTalk <= 6.10 - Missing Authorization CVE-2023-33996 6.3 Rafshanzani Suhada June 22, 2023
AntiSpam by CleanTalk <= 5.185 - Authenticated (Administrator+) SQL Injection CVE-2022-3302 7.2 Nguyen Duy Quoc Khanh October 3, 2022
Spam protection, AntiSpam, FireWall by CleanTalk <= 5.173 - Reflected Cross-Site Scripting CVE-2022-28222 6.1 Ram March 30, 2022
Spam protection, AntiSpam, FireWall by CleanTalk <= 5.173 - Reflected Cross-Site Scripting CVE-2022-28221 6.1 Ram March 30, 2022
Spam protection, AntiSpam, FireWall by CleanTalk <= 5.153.3 - Unauthenticated Blind SQL Injection CVE-2021-24295 7.5 Ram March 5, 2021
Anti-Spam by CleanTalk < 5.149 - Authenticated SQL Injection CVE-2021-24131 7.2 Nguyen Anh Tien November 20, 2020
Spam protection, AntiSpam, FireWall by CleanTalk <= 5.127.3 - Reflected Cross-Site Scripting CVE-2019-17515 6.1 November 12, 2019
Spam protection, AntiSpam, FireWall by CleanTalk < 5.22 - Reflected Cross-Site Scripting 6.1 Marcin Probola August 25, 2015

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation