Beaver Builder – WordPress Page Builder

Information

Software Type Plugin
Software Slug beaver-builder-lite-version (view on wordpress.org)
Software Status Active
Software Author justinbusa
Software Website www.wpbeaverbuilder.com
Software Downloads 10,165,860
Software Active Installs 100,000
Software Record Last Updated May 24, 2024

16 Vulnerabilities

Title Status CVE ID CVSS Researchers Date
Beaver Builder <= 2.8.1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via photo widget crop attribute Patched CVE-2024-4430 6.4 Thanh Nam Tran May 10, 2024
Beaver Builder – WordPress Page Builder <= 2.8.1.1 - Authenticated (Contributor+) Stored Cross-Site Scripting Patched CVE-2024-3923 6.4 wesley (wcraft) May 7, 2024
Beaver Builder – WordPress Page Builder <= 2.8.0.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Button Patched CVE-2024-2925 6.4 wesley (wcraft) April 1, 2024
Beaver Builder – WordPress Page Builder <= 2.7.4.4 - Authenticated(Contributor+) Stored Cross-Site Scripting via heading tag Patched CVE-2024-1080 6.4 Nikolas March 11, 2024
Beaver Builder – WordPress Page Builder <= 2.7.4.2 - Authenticated(Contributor+) Stored Cross-Site Scripting via Audio Widget Patched CVE-2024-1074 6.4 RandomRoot February 28, 2024
Beaver Builder – WordPress Page Builder <= 2.7.4.2 - Authenticated (Contributor+) Stored Cross-Site Scripting Patched CVE-2024-0897 6.4 RandomRoot February 20, 2024
Beaver Builder – WordPress Page Builder <= 2.7.4.2 - Authenticated (Contributor+) Stored Cross-Site Scripting Patched CVE-2024-0896 6.4 RandomRoot, wesley (wcraft), Nikolas February 20, 2024
Beaver Builder – WordPress Page Builder <= 2.5.5.2 - Authenticated Stored Cross-Site Scripting via Text Editor Patched CVE-2022-2716 6.4 Zhouyuan Yang August 29, 2022
Beaver Builder – WordPress Page Builder <= 2.5.5.2 - Authenticated Stored Cross-Site Scripting via Caption - On Hover Patched CVE-2022-2517 6.4 Zhouyuan Yang August 29, 2022
Beaver Builder – WordPress Page Builder <= 2.5.5.2 - Authenticated Stored Cross-Site Scripting via Image URL Patched CVE-2022-2934 6.4 Zhouyuan Yang August 29, 2022
Beaver Builder – WordPress Page Builder <= 2.5.5.2 - Authenticated Stored Cross-Site Scripting via 'caption' Patched CVE-2022-2695 6.4 Zhouyuan Yang August 29, 2022
Beaver Builder – WordPress Page Builder (Free & Pro) <= 1.7 - Authorization Bypass Patched 6.3 James Golovich February 8, 2016
Beaver Builder – WordPress Page Builder <= 2.7.4.2 - Reflected (DOM-Based) Cross-Site Scripting Patched CVE-2024-1038 5.4 wesley (wcraft) February 20, 2024
Beaver Builder <= 2.7.4.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Icon Widget Patched CVE-2024-0871 5.4 wesley (wcraft), Nikolas Santos (Mdr01 Salokin) February 20, 2024
Beaver Builder <= 2.5.4.3 - Missing Authorization Patched CVE-2022-36425 5.4 Dave Jong July 20, 2022
Beaver Builder – WordPress Page Builder <= 2.7.2 - Authenticated (Contributor+) Stored Cross-Site Scripting Patched CVE-2023-50889 5.3 Rafie Muhammad December 26, 2023

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation