Link Library

Information

Software Type Plugin
Software Slug link-library (view on wordpress.org)
Software Status Active
Software Author jackdewey
Software Website wordpress.org
Software Downloads 2,276,660
Software Active Installs 10,000
Software Record Last Updated May 23, 2024

13 Vulnerabilities

7.2
CVE ID Unknown
Aug 14, 2017
Researcher: Lenon Leite
Title Status CVE ID CVSS Researchers Date
Link Library <= 5.9.13.26 – SQL Injection Patched 7.2 Lenon Leite August 14, 2017
Link Library <= 7.6 - Unauthenticated Stored Cross-Site Scripting Patched CVE-2024-1559 6.5 Krzysztof Zając February 19, 2024
Link Library <= 7.6.11 - Authenticated (Contributor+) Stored Cross-Site Scripting via link-library Shortcode Patched CVE-2024-4281 6.4 Krzysztof Zając May 7, 2024
Link Library <= 7.6 - Reflected Cross-Site Scripting Patched CVE-2024-29123 6.1 stealthcopter March 16, 2024
Link Library <= 7.6.6 - Reflected Cross-Site Scripting Patched CVE-2024-2325 6.1 Krzysztof Zając March 13, 2024
Link Library <= 7.5.13 - Reflected Cross-Site Scripting via 'link_price' and 'link_tags' Patched CVE-2024-24879 6.1 beluga February 5, 2024
Link Library <= 7.2.8 - Reflected Cross-Site Scripting Patched CVE-2021-25091 6.1 Krzysztof Zając December 30, 2021
Link Library <= 5.9.12.29 - Reflected Cross-Site Scripting Patched 6.1 Burak Kelebek August 15, 2016
Link Library <= 5.8.10.6 - Reflected Cross-Site Scripting Patched 6.1 Kacper Szurek November 8, 2014
Link Library <= 7.4 - Authenticated (Admin+) Stored Cross-Site Scripting Patched CVE-2022-4199 5.5 iohex December 23, 2022
Link Library <= 7.2.7 - Missing Authorization Checks Patched CVE-2021-25093 5.3 Krzysztof Zając December 30, 2021
Link Library <= 7.5.13 - Cross-Site Request Forgery via action_admin_init Patched CVE-2024-24875 4.3 Dhabaleshwar Das February 5, 2024
Link Library <= 7.2.7 - Cross-Site Request Forgery to Library Settings Reset Patched CVE-2021-25092 4.3 Krzysztof Zając December 30, 2021

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation