Multiple Page Generator Plugin – MPG

Information

Software Type Plugin
Software Slug multiple-pages-generator-by-porthas (view on wordpress.org)
Software Status Active
Software Author themeisle
Software Website themeisle.com
Software Downloads 74,131
Software Active Installs 3,000
Software Record Last Updated April 15, 2024

9 Vulnerabilities

Title CVE ID CVSS Researchers Date
Multiple Page Generator Plugin – MPG <= 3.4.0 - Cross-Site Request Forgery CVE-2024-31301 4.3 Majed Refaea April 5, 2024
Multiple Page Generator Plugin – MPG <= 3.4.0 - Missing Authorization via mpg_get_log_by_project_id CVE-2024-30235 4.3 Majed Refaea March 26, 2024
Multiple Page Generator Plugin – MPG <= 3.4.0 - Authenticated (Editor+) Remote Code Execution CVE-2024-27951 7.2 Majed Refaea March 13, 2024
ThemeIsle SDK <= Various Versions - Missing Authorization CVE-2024-1047 5.3 Francesco Carlucci February 1, 2024
Freemius SDK <= 2.5.9 - Reflected Cross-Site Scripting via fs_request_get CVE-2023-33999 6.1 Rafie Muhammad July 18, 2023
Multiple Page Generator Plugin – MPG <= 3.3.19 - Authenticated (Administrator+) SQL Injection in projects_list and total_projects CVE-2023-33927 7.2 LEE SE HYOUNG May 23, 2023
Multiple Page Generator Plugin <= 3.3.17 - Cross-Site Request Forgery to SQL Injection CVE-2023-2608 3.1 Marco Wotschka May 16, 2023
Multiple Page Generator Plugin <= 3.3.17 - Authenticated (Administrator+) SQL Injection CVE-2023-2607 7.2 Marco Wotschka May 16, 2023
Multiple Page Generator Plugin <= 3.3.9 - Cross-Site Request Forgery CVE-2022-47143 6.3 rezaduty February 20, 2023

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation