Elementor Website Builder – More than Just a Page Builder

Information

Software Type Plugin
Software Slug elementor (view on wordpress.org)
Software Status Active
Software Author elemntor
Software Website elementor.com
Software Downloads 467,241,084
Software Active Installs 10,000,000
Software Record Last Updated July 24, 2024

Showing 1-20 of 33 Vulnerabilities

5.4
CVE ID Unknown
May 12, 2023
Researchers:
Title Status CVE ID CVSS Researchers Date
Elementor Website Builder <= 3.22.1 - Authenticated (Contributor+) Arbitrary SVG Download Patched CVE-2024-37437 6.4 stealthcopter June 28, 2024
Elementor Website Builder – More than Just a Page Builder <= 3.21.5 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting Patched CVE-2024-4619 6.4 Webbernaut May 20, 2024
Elementor Website Builder – More than Just a Page Builder <= 3.20.2 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting via Path Widget Patched CVE-2024-2117 6.4 Webbernaut March 26, 2024
Elementor <= 3.19.0 - Authenticated(Contributor+) Arbitrary File Deletion and PHAR Deserialization Patched CVE-2024-24934 8.8 Rhynorater February 7, 2024
Elementor Website Builder – More than Just a Page Builder <= 3.18.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via get_image_alt Patched CVE-2024-0506 6.4 wesley (wcraft) February 7, 2024
Elementor <= 3.18.1 - Authenticated(Contributor+) Arbitrary File Upload to Remote Code Execution via Template Import Patched CVE-2023-48777 8.8 Hong Quan December 6, 2023
Elementor Website Builder <= 3.16.4 - Missing Authorization to Arbitrary Attachment Read Patched CVE-2023-47504 6.5 Rafie Muhammad November 8, 2023
Elementor Website Builder <= 3.16.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via get_inline_svg() Patched CVE-2023-47505 6.4 Rafie Muhammad November 8, 2023
Elementor <= 3.5.4 - DOM-Based iFrame Injection Patched CVE-2022-4953 6.1 Miguel Santareno July 19, 2023
Elementor <= 3.13.2 Authenticated(Contributor+) Arbitrary Post Type Creation via save_item Patched CVE-2023-33922 5.4 Rafie Muhammad May 22, 2023
Elementor <= 3.13.1 - Missing Authorization to Settings Update Patched 5.4 May 12, 2023
Elementor <= 3.12.1 - Authenticated(Administrator+) SQL Injection via 'replace_urls' Patched CVE-2023-0329 6.6 Sanjay Das April 24, 2023
Elementor Website Builder <= 3.5.5 - Unauthenticated DOM-based Reflected Cross-Site Scripting Patched CVE-2022-29455 6.1 Rotem Bar, Gal Nagli, Tomer Zait June 13, 2022
Elementor Website Builder 3.6.0 - 3.6.2 - Missing Authorization to Remote Code Execution Patched CVE-2022-1329 8.8 Ram April 13, 2022
Elementor Website Builder <= 3.4.7 - DOM-based Cross-Site Scripting Patched CVE-2021-24891 6.1 Joel Beleña March 23, 2021
Elementor Website Builder <= 3.1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via html_tag Patched CVE-2021-24203 6.4 Ram March 17, 2021
Elementor Website Builder <= 3.1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via title_html_tag Patched CVE-2021-24204 6.4 Ram March 17, 2021
Elementor Website Builder <= 3.1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via title_size Patched CVE-2021-24206 6.4 Ram March 17, 2021
Elementor Website Builder <= 3.1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via html_tag Patched CVE-2021-24201 6.4 Ram March 17, 2021
Elementor Website Builder <= 3.1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via header_size Patched CVE-2021-24202 6.4 Ram March 17, 2021

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation